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Membangun Aplikasi 

Sistem Informasi Pegawai 
 

 

1. Pengenalan ADO 

Microsoft ActiveX Data Object (ADO) memungkinkan kita untuk membangun aplikasi client/server yang dapat 

mengakses dan memanipulasi data dari sebuah server dengan terlebih dahulu menentukan provider OLE DB-

nya. Dengan adanya ADO, program aplikasi yang dibuat mampu berkomunikasi dengan Object Linking and 

Embeded Database (OLE DB) yang memungkinkan kita membaca dan mengilah data secara langsung tanpa 

perlu mengkonversinya terlebih dahulu 

 

2. Pembangunan Software Sistem Informasi Pegawai (SIPEG) 

Sistem Informasi Pegawai (SIPEG) adalah software yang bertujuan untuk mengelola (menambah, 

memperbarui, menghapus, dan menyajikan) data-data pegawai dari suatu perusahaan. Software ini 

mempunyai beberapa modul (fasilitas) yang diberikan kepada pengguna sistem tunggal dari SIPEG yaitu 

seorang administrator. Adapun modul-modul yang akan diberikan kepada seorang administrator adalah 

sebagai berikut: 

‐ Modul Login ke sistem 

‐ Modul Pengelolaan Data Pegawai 

‐ Modul Ganti Password User 

 

2.1. Struktur Database SIPEG 

Database akan digunakan sebagai alat untuk storage data yang nantinya akan diolah untuk disajikan kepada 

pengguna sistem. Adapun struktur database SIPEG adalah sebagai berikut 

 

2.1.1. Nama Database 

Buatlah database untuk SIPEG dengan nama pegawai_db. 

 

2.1.2. Tabel admin 

Nama Kolom Tipe Data (panjang) Kunci 

Username Varchar (25) Primary Key 

Password Varchar (25) - 

 

2.1.3 Tabel data_pegawai 

Nama Kolom Tipe Data (Panjang) Kunci 

Nip Varchar (8) Primary Key 

Nama Varchar (50) - 

Jenis_kelamin Varchar (15) - 

Tempat_lahir Varchar (25) - 

Tgl_lahir Varchar (10) - 

Agama Varchar (20) - 

Status Varchar (15) - 

Alamat text - 
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2.2.  Membuat Form Utama 

Aplikasi yang akan dibangun merupakan aplikasi yang menggunakan MDI form (Multiple Document Interface). 

Untuk lebih jelasnya ikuti langkah-langkah berikut ini: 

1. Buatlah project baru dengan pilihan Standart EXE, kemudian aturlah property Form1 sebagai berikut 

Objek Property Pengaturan 

Project1 Name SIPEG 

 

2. Tambahkan MDI form, melalui menu Project > Add MDI Form, klik Open. 

3. Pada MDI Form ini buatlah menu seperti terlihat pada Tabel , dengan mengklik menu Tool > Menu 

Editor 

Level Caption Name 

0 File mnFile 

1 Login mnLogin 

1 Logout mnLogout 

1 - mnBatas 

1 Exit mnExit 

0 Administrasi Data  mnOlahData 

1 Data Pegawai mnPegawai 

0 Account mnAccount 

1 Ganti Password mnGantiPassword 

 

 

Gambar 1 Tampilan Menu Editor 
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Gambar 2 Form Utama (frmUtama) 

 

4. Ubahlah property Nama MDI form yang baru saja terbentuk: 

Objek Property Pengaturan 

MDIForm1 Name 

WindowState 

frmUtama 

2-Maximize 

 

5. Tambahkan references pada menu Project > References > Microsoft ActiveX Data Objects 2.5 

Library.  

6. Tambahkan 2 komponen sekaligus dengan cara CTRL + T > centang Microsoft Windows Common 

Control-2 6.0 dan centang juga Microsoft FlexGrid Controls 6.0 

7.  Langkah berikutnya adalah simpanlah terlebih dahulu projek anda sebelum anda melangkah lebih 

jauh dengan cara File > Save Project, muncul window Save As Project > buatlah 1 buah 

folder/direktori, beri direktori yang baru saja terbentuk dengan nama SIPEG APP.vbp > klik Open > 

Klik tombol Save. Untuk frmUtama, simpan dengan nama frmUtama.frm > klik tombol Save. 

8. Kemudian arahkan perhatian anda pada window Project Explorer > klik frmUtama > muncul 

window designer dari frmUtama > double click frmUtama. Ketikkan kode-kode seperti di bawah 

ini 

Private Sub MDIForm_Load() 

    Move (Screen.Width - Width) / 2, (Screen.Height - Height) / 3 

     

    frmLogin.Show 

    mnOlahData.Enabled = False 

    mnLogout.Enabled = False 

    mnAccount.Enabled = False 

End Sub 

--------------------------------------------------------------------- 

Private Sub mnExit_Click() 

    End 

End Sub 
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--------------------------------------------------------------------- 

Private Sub mnGantiPassword_Click() 

    frmGantiPassword.Show 

End Sub 

--------------------------------------------------------------------- 

Private Sub mnLogin_Click() 

    frmLogin.Show 

End Sub 

--------------------------------------------------------------------- 

Private Sub mnLogout_Click() 

    mnOlahData.Enabled = False 

    mnLogin.Enabled = True 

    mnLogout.Enabled = False 

    mnAccount.Enabled = False 

    frmLogin.txtUsername.Text = "" 

    frmLogin.txtPassword.Text = "" 

End Sub 

--------------------------------------------------------------------- 

Private Sub mnPegawai_Click() 

    frmPegawai.Show 

End Sub 

 

2.3. Menggunakan Modul 

Modul biasa dipakai untuk mendeklarasikan semua variabel dan fungsi-fungsi yang bersifat public, yang dapat 

dipakai pada semua form. Untuk lebih jelasnya, tambahkan modul tersebut dengan mengklik menu Project > 

Add Module > Open. Ketiklah listing module1.bas berikut dan simpan dengan nama Module1.bas 

 

Public objCnn As New ADODB.Connection 

Public objcmd As New ADODB.Command 

Public objRst As New ADODB.Recordset 

Public USRText As String 

Public PWDText As String 

Public PortText As String 

Public strconnect As String 

Public ServerAddress As String 

Public DatabaseName As String 

 

Sub SQLConnection() 

    ServerAddress = "localhost" 

    USRText = "root" 

    PWDText = "" 

    DatabaseName = "pegawai_db" 'Diisi database mana yang akan digunakan 

    PortText = "" 

    Set objCnn = Nothing 

    strconnect = "Provider=MSDASQL.1;Password=;Persist Security Info=True;User ID=;Extended 
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Properties=" & Chr$(34) & _ 

    "DRIVER={MySQL ODBC 5.1 Driver}; DESC=;DATABASE=" & DatabaseName & "; SERVER=" & 

ServerAddress & ";UID=" & USRText & ";PASSWORD=" & PWDText & ";PORT=" & PortText & "; 

OPTION=16387;STMT=;" & Chr$(34) 

    objCnn.CursorLocation = adUseClient 

    objCnn.ConnectionTimeout = 0 

    objCnn.Open strconnect 

End Sub 

--------------------------------------------------------------------- 

Sub SQLDisconnection() 

    Set objRst = Nothing 

    Set objcmd = Nothing 

    objCnn.Close 

End Sub 

 

2.4.  Form Login 

Form login merupakan form yang digunakan untuk autentikasi pengguna sistem, apakah pengguna benar-

benar mempunyai hak untuk mengakses sistem atau tidak. Form ini akan disajikan pertama kali saat sistem 

dijalankan. Untuk lebih jelasnya ikuti langkah-langkah pembuatannya berikut ini:  

1. Tambahkan satu form dengan cara menu Project > Add Form, pilih Form da klik Open. 

2. Desainlah form seperti gambar dibawah ini 

 

Gambar 3 Desain form login 

 

3. Kemudian tambahkan beberapa objek sesuai pada tabel dan susunlah objek-objek tersebut seberti 

pada gambar 3 

Objek Property Pengaturan 

Form Name 

BorderStyle 

MDIChild 

Caption 

Font 

frmLogin 

4-FixedToolWindow 

True 

.: LOGIN :. 

Segoe UI, regular, 9 

Label1 Caption Username 

Label2 Caption Password 

Text1 Name 

Appearance 

BorderStyle 

Text 

txtUsername 

0-Flat 

1-FixedSingle 
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Text2 Name 

Appearance 

BorderStyle 

Text 

txtPassword 

0-Flat 

1-FixedSingle 

Command1 Name 

Caption 

cmdLogin 

LOGIN 

Command2 Name 

Caption 

cmdCancel 

CANCEL 

 

4. Ketikkan code listing frmLogin berikut dan simpan dengan nama frmLogin.frm 

Private Sub cmdCancel_Click() 

    Unload Me 

End Sub 

--------------------------------------------------------------------- 

 

Private Sub cmdLogin_Click() 

    Dim stm As String 

    Dim rsLogin As ADODB.Recordset 

     

    Set rsLogin = New ADODB.Recordset 

    stm = "select * from admin" 

    rsLogin.Open stm, strconnect, , adLockOptimistic 

    rsLogin.MoveFirst 

    If (txtUsername.Text = rsLogin!username) And (txtPassword.Text = rsLogin!password) 

Then 

        frmUtama.mnLogin.Enabled = False 

        frmUtama.mnOlahData.Enabled = True 

        frmUtama.mnLogout.Enabled = True 

        frmUtama.mnAccount.Enabled = True 

        frmLogin.Visible = False 

        MsgBox "Selamat Anda Berhasil Masuk Ke Sistem", vbInformation + vbOKOnly, 

"SUKSES LOGIN" 

    Else 

        MsgBox "Username dan Password Tidak Cocok", vbCritical + vbOKOnly, "LOGIN 

GAGAL" 

        txtUsername.Text = "" 

        txtPassword.Text = "" 

        txtUsername.SetFocus 

    End If 

End Sub 

--------------------------------------------------------------------- 

 

Private Sub Form_Load() 

    Move (Screen.Width - Width) / 2, (Screen.Height - Height) / 3 

    Call SQLConnection 

End Sub 

 

2.5. Form Administrasi Data Pegawai 
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Form administrasi data pegawai digunakan untuk melakukan pengelolaan data-data pegawai baik menambah 

data baru, menghapus data lama, memperbarui data pegawai yang sudah ada maupun menyajikan data 

pegawai kepada pengguna sistem. Berikut adalah langkah-langkah pembuatannya 

1. Tambahkan satu form baru dengan Project > Add Project, Pilih Form kemudian Klik Open. 

2. Desainlah form seperti gambar dibawah ini 

 

Gambar 4 Desain form Data Pegawai 

 

3. Tambahkan beberapa objek sesuai dengan tabel dan susunlan objek-objek tersebut seperti pada gambar 4 

Objek Property Pengaturan 

Form Name 

BorderStyle 

MDIChild 

Caption 

Font 

frmLogin 

4-FixedToolWindow 

True 

.: LOGIN :. 

Segoe UI, regular, 9 

Frame1 Caption Data Pegawai 

Frame2 Caption Pencarian 

Frame3 Caption  

Label1 Caption NIP 

Label2 Caption Nama 

Label3 Caption Jenis Kelamin 

Label4 Caption Tempat/Tgl Lahir 

Label5 Caption / 

Label6 Caption Agama 

Label7 Caption Status 

Label8 Caption Alamat 

Label9 Caption Filter 

Label10 Caption Katakunci 

Command1 Name 

Caption 

cmdTambah 

TAMBAH 

Command2 Name cmdSimpan 
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Caption SIMPAN 

Command3 Name 

Caption 

cmdEdit 

EDIT 

Command4 Name 

Caption 

cmdHapus 

HAPUS 

Command5 Name 

Caption 

cmdRefresh 

REFRESH 

Command6 Name 

Caption 

cmdKeluar 

KELUAR 

Command7 Name 

Caption 

cmdCari 

CARI 

Text1 Name 

Appearance 

BorderStyle 

Text 

txtNip 

0-Flat 

1-FixedSingle 

Text2 Name 

Appearance 

BorderStyle 

Text 

txtNama 

0-Flat 

1-FixedSingle 

Text3 Name 

Appearance 

BorderStyle 

Text 

txtTempat 

0-Flat 

1-FixedSingle 

Text4 Name 

Appearance 

BorderStyle 

Text 

txtAlamat 

0-Flat 

1-FixedSingle 

Text5 Name 

Appearance 

BorderStyle 

Text 

txtKeyword 

0-Flat 

1-FixedSingle 

Combo1 Name cmbJk 

Combo2 Name cmbAgama 

Combo3 Name cmdFilter 

Option1 Name 

Caption 

optKawin 

Kawin 

Option2 Name 

Caption 

optBelumKawin 

Belum Kawin 

DTPicker1 Name txtTanggal 

MSFlexGrid1 Name 

Cols  

flexGrid 

4 

 

4. Ketikkan code listing dari frmPegawai dibawah ini kemudian simpan dengan nama frmPegawai.frm 

Dim rsPegawai As ADODB.Recordset 

Dim stm As String 
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Private Sub cmbNip_Click() 

    Dim ketemu As Boolean 

     

    SQLConnection 

    Set rsPegawai = New ADODB.Recordset 

    stm = "select * from data_pegawai where nip='" & cmbNip.Text & "'" 

    rsPegawai.Open stm, strconnect, , adLockOptimistic 

    txtNama.Text = rsPegawai!nama 

    If (rsPegawai!jenis_kelamin = "Laki-laki") Then 

        cmbJk.Text = rsPegawai!jenis_kelamin 

    Else 

        cmbJk.Text = rsPegawai!jenis_kelamin 

    End If 

    txtTempat.Text = rsPegawai!tempat_lahir 

    txtTglLahir.Text = rsPegawai!tgl_lahir 

    If (rsPegawai!agama = "Islam") Then 

        cmbAgama.Text = rsPegawai!agama 

    ElseIf (rsPegawai!agama = "Kristen") Then 

        cmbAgama.Text = rsPegawai!agama 

    ElseIf (rsPegawai!agama = "Katolik") Then 

        cmbAgama.Text = rsPegawai!agama 

    ElseIf (rsPegawai!agama = "Hindu") Then 

        cmbAgama.Text = rsPegawai!agama 

    ElseIf (rsPegawai!agama = "Budha") Then 

        cmbAgama.Text = rsPegawai!agama 

    End If 

    If rsPegawai!status = "Kawin" Then 

        optKawin.Value = True 

    Else 

        optBelumKawin.Value = True 

    End If 

    txtAlamat.Text = rsPegawai!alamat 

End Sub 

--------------------------------------------------------------------- 

 

Private Sub cmdCari_Click() 

On Error Resume Next 

    Dim baris As Integer 

     

    flexGrid.Clear 

    activeDataGrid 

     

    flexGrid.Rows = 2 

    baris = 0 

 

    Set rsPegawai = New ADODB.Recordset 

    stm = "select * from data_pegawai where " & cmbFilter & " like '%" & 
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UCase(txtKeyword.Text) & "%'" 

    rsPegawai.Open stm, strconnect 

     

    If rsPegawai.BOF Then 

        MsgBox "Data Pegawai Tidak Ditemukan!", vbInformation + vbOKOnly, "Perhatian" 

        Exit Sub 

    Else 

        With rsPegawai 

            .MoveFirst 

            Do While Not .EOF 

                On Error Resume Next 

                baris = baris + 1 

                flexGrid.Rows = baris + 1 

                flexGrid.TextMatrix(baris, 0) = !nip 

                flexGrid.TextMatrix(baris, 1) = !nama 

                flexGrid.TextMatrix(baris, 2) = !jenis_kelamin 

                flexGrid.TextMatrix(baris, 3) = !tempat_lahir 

                .MoveNext 

            Loop 

        End With 

    End If 

End Sub 

--------------------------------------------------------------------- 

 

Private Sub cmdEdit_Click() 

    Set rsPegawai = New ADODB.Recordset 

     

    If txtNip.Text = "" Then 

        MsgBox "Data yang akan diperbarui tidak ada!" & vbCrLf & "Silakan klik ganda 

salah satu data pada tabel", vbCritical + vbOKOnly, "Perhatian" 

    Else 

        If optKawin.Value = True Then 

            stm = "update data_pegawai set nip='" & txtNip.Text & "', nama='" & 

txtNama.Text & "', jenis_kelamin='" & cmbJk.Text & "', tempat_lahir='" & txtTempat.Text & 

"', tgl_lahir='" & txtTanggal.Value & "', agama='" & cmbAgama.Text & "', status='" & 

optKawin.Caption & "', alamat='" & txtAlamat.Text & "'" 

            rsPegawai.Open stm, strconnect 

            MsgBox "Data dengan NIP " & txtNip.Text & " Berhasil Diperbarui", 

vbInformation + vbOKOnly, "Informasi" 

            showDataGrid 

        ElseIf optBelumKawin.Value = True Then 

            stm = "update data_pegawai set nip='" & txtNip.Text & "', nama='" & 

txtNama.Text & "', jenis_kelamin='" & cmbJk.Text & "', tempat_lahir='" & txtTempat.Text & 

"', tgl_lahir='" & txtTanggal.Value & "', agama='" & cmbAgama.Text & "', status='" & 

optBelumKawin.Caption & "', alamat='" & txtAlamat.Text & "'" 

            rsPegawai.Open stm, strconnect 

            MsgBox "Data dengan NIP " & txtNip.Text & " Berhasil Diperbarui", 

vbInformation + vbOKOnly, "Informasi" 
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            showDataGrid 

        Else 

            stm = "update data_pegawai set nip='" & txtNip.Text & "', nama='" & 

txtNama.Text & "', jenis_kelamin='" & cmbJk.Text & "', tempat_lahir='" & txtTempat.Text & 

"', tgl_lahir='" & txtTanggal.Value & "', agama='" & cmbAgama.Text & "', alamat='" & 

txtAlamat.Text & "'" 

            rsPegawai.Open stm, strconnect 

            MsgBox "Data dengan NIP " & txtNip.Text & " Berhasil Diperbarui", 

vbInformation + vbOKOnly, "Informasi" 

            showDataGrid 

        End If 

    End If 

End Sub 

--------------------------------------------------------------------- 

 

Private Sub cmdHapus_Click() 

    If txtNip.Text = "" Then 

        MsgBox "Data yang akan diperbarui tidak ada!" & vbCrLf & "Silakan klik ganda 

salah satu data pada tabel", vbCritical + vbOKOnly, "Perhatian" 

    Else 

        pesan = MsgBox("Apakah Anda Yakin Menghapus?", vbYesNo + vbInformation, 

"KONFIRMASI") 

        If pesan = vbYes Then 

            Set rsPegawai = New ADODB.Recordset 

            stm = "delete from data_pegawai where nip='" & txtNip.Text & "'" 

            rsPegawai.Open stm, strconnect 

            Call bersihkan_form 

            showDataGrid 

        Else 

            Exit Sub 

        End If 

    End If 

End Sub 

--------------------------------------------------------------------- 

 

Private Sub cmdKeluar_Click() 

    Unload Me 

End Sub 

--------------------------------------------------------------------- 

 

Private Sub cmdRefresh_Click() 

    Call showDataGrid 

End Sub 

--------------------------------------------------------------------- 

 

Private Sub cmdSimpan_Click() 

    Dim rsPegawai2 As ADODB.Recordset 

    Dim stm2 As String 
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    Dim jumlah_pegawai As Integer 

     

    If txtNip.Text = "" Then 

        MsgBox "NIP Tidak Boleh Kosong", vbCritical + vbOKOnly, "Peringatan" 

        txtNip.SetFocus 

    ElseIf txtNama.Text = "" Then 

        MsgBox "Nama Tidak Boleh Kosong", vbCritical + vbOKOnly, "Peringatan" 

        txtNama.SetFocus 

    Else 

        'Cek nip 

        Set rsPegawai = New ADODB.Recordset 

        stm = "select count(nip) as jumlah from data_pegawai where nip='" & txtNip.Text & 

"'" 

        rsPegawai.Open stm, strconnect 

         

        jumlah_pegawai = rsPegawai!jumlah 

         

        If jumlah_pegawai = 0 Then 

            Set rsPegawai2 = New ADODB.Recordset 

             

            If optBelumKawin.Value = True Then 

                stm2 = "insert into data_pegawai values ('" & txtNip.Text & "', '" & 

txtNama.Text & "', '" & cmbJk.Text & "', '" & txtTempat.Text & "', '" & txtTanggal.Value 

& "', '" & cmbAgama.Text & "', '" & optBelumKawin.Caption & "', '" & txtAlamat.Text & 

"')" 

                rsPegawai2.Open stm2, strconnect 

            ElseIf optKawin.Value = True Then 

                stm2 = "insert into data_pegawai values ('" & txtNip.Text & "', '" & 

txtNama.Text & "', '" & cmbJk.Text & "', '" & txtTempat.Text & "', '" & txtTanggal.Value 

& "', '" & cmbAgama.Text & "', '" & optKawin.Caption & "', '" & txtAlamat.Text & "')" 

                rsPegawai2.Open stm2, strconnect 

            End If 

            MsgBox "Data berhasil ditambahkan", vbInformation + vbOKOnly, "Informasi" 

            Call showDataGrid 

        Else 

            MsgBox "NIP Tidak Boleh Sama", vbCritical + vbOKOnly, "Perhatian" 

            txtNip.Text = "" 

            txtNip.SetFocus 

        End If 

    End If 

End Sub 

--------------------------------------------------------------------- 

 

Private Sub cmdTambah_Click() 

    txtNip.Enabled = True 

    Call bersihkan_form 

    txtNip.SetFocus 

End Sub 
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--------------------------------------------------------------------- 

 

Sub bersihkan_form() 

    txtNip.Text = "" 

    txtNama.Text = "" 

    cmbJk.Text = "" 

    txtTempat.Text = "" 

    txtTanggal.Value = Now 

    cmbAgama.Text = "" 

    optKawin.Value = True 

    optBelumKawin.Value = False 

    txtAlamat.Text = "" 

End Sub 

--------------------------------------------------------------------- 

 

Private Sub cmdUbah_Click() 

    Dim status As String 

     

    SQLConnection 

    Set rsPegawai = New ADODB.Recordset 

    If (optKawin.Value = True) Then 

        status = optKawin.Caption 

    Else 

        status = optBelumKawin.Caption 

    End If 

    stm = "update data_pegawai set nama='" & txtNama.Text & "', jenis_kelamin='" & 

cmbJk.Text & "', tempat_lahir='" & txtTempat.Text & "', tgl_lahir='" & txtTglLahir.Text & 

"', agama='" & cmbAgama.Text & "', status='" & status & "', alamat='" & txtAlamat.Text & 

"' where nip='" & cmbNip.Text & "'" 

    rsPegawai.Open stm, strconnect, , adLockOptimistic 

    MsgBox "Data dengan nip " & cmbNip.Text & " Berhasil Diupdate", vbInformation + 

vbOKOnly, "KONFIRMASI" 

End Sub 

--------------------------------------------------------------------- 

 

Private Sub flexGrid_DblClick() 

On Error Resume Next 

    txtNip.Enabled = False 

    txtNama.SetFocus 

    gridObjIndex = flexGrid.Row 

     

    Set rsPegawai = New ADODB.Recordset 

    stm = "select * from data_pegawai where nip='" & flexGrid.TextMatrix(gridObjIndex, 0) 

& "'" 

    rsPegawai.Open stm, strconnect 

     

    If rsPegawai.BOF Then 

        MsgBox "Data Pegawai Masih Kosong", vbInformation + vbOKOnly, "Informasi" 
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        Exit Sub 

    Else 

        rsPegawai.MoveFirst 

        Do While Not rsPegawai.EOF 

            txtNip.Text = rsPegawai!nip 

            txtNama.Text = rsPegawai!nama 

            cmbJk.Text = rsPegawai!jenis_kelamin 

            txtTempat.Text = rsPegawai!tempat_lahir 

            txtTanggal.Value = rsPegawai!tgl_lahir 

            cmbAgama.Text = rsPegawai!agama 

            If rsPegawai!status = "Belum Kawin" Then 

                optBelumKawin.Value = True 

            ElseIf rsPegawai!status = "Kawin" Then 

                optKawin.Value = True 

            Else 

                optKawin.Value = False 

                optBelumKawin.Value = False 

            End If 

            txtAlamat.Text = rsPegawai!alamat 

            rsPegawai.MoveNext 

        Loop 

    End If 

End Sub 

--------------------------------------------------------------------- 

 

Private Sub Form_Activate() 

    Dim stm2 As String 

     

    Move (Screen.Width - Width) / 2, (Screen.Height - Height) / 3 

    txtNip.SetFocus 

    SQLConnection 

    Set rsPegawai = New ADODB.Recordset 

    stm2 = "select count(*) as jumlah from data_pegawai" 

    rsPegawai.Open stm2, strconnect, , adLockOptimistic 

    If jumlah <> 0 Then 

        stm = "select nip from data_pegawai" 

        rsPegawai.Open stm, strconnect, , adLockOptimistic 

        rsPegawai.MoveFirst 

        Do Until rsPegawai.EOF 

            cmbNip.AddItem (rsPegawai!nip) 

            rsPegawai.MoveNext 

        Loop 

    End If 

     

    Call activeDataGrid 

    Call showDataGrid 

    Call isiCmbFilter 

End Sub 
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--------------------------------------------------------------------- 

 

Sub activeDataGrid() 

    With flexGrid 

        .RowHeightMin = 300 

         

        .Col = 0 

        .Row = 0 

        .Text = "NIP" 

        .ColWidth(0) = 1000 

        .AllowUserResizing = flexResizeColumns 

        .CellAlignment = flexAlignCenterCenter 

         

        .Col = 1 

        .Row = 0 

        .Text = "NAMA LENGKAP" 

        .ColWidth(1) = 3000 

        .AllowUserResizing = flexResizeColumns 

        .CellAlignment = flexAlignCenterCenter 

         

        .Col = 2 

        .Row = 0 

        .Text = "JENIS KELAMIN" 

        .ColWidth(2) = 1500 

        .AllowUserResizing = flexResizeColumns 

        .CellAlignment = flexAlignCenterCenter 

         

        .Col = 3 

        .Row = 0 

        .Text = "TEMPAT LAHIR" 

        .ColWidth(3) = 2000 

        .AllowUserResizing = flexResizeColumns 

        .CellAlignment = flexAlignCenterCenter 

    End With 

End Sub 

--------------------------------------------------------------------- 

 

Sub showDataGrid() 

    Dim baris As Integer 

     

    flexGrid.Clear 

    activeDataGrid 

     

    flexGrid.Rows = 2 

    baris = 0 

     

    Set rsPegawai = New ADODB.Recordset 

    stm = "select * from data_pegawai" 
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    rsPegawai.Open stm, strconnect 

     

    If rsPegawai.BOF Then 

        MsgBox "Data Pegawai Masih Kosong!", vbInformation + vbOKOnly, "Perhatian" 

        Exit Sub 

    Else 

        With rsPegawai 

            .MoveFirst 

            Do While Not .EOF 

                On Error Resume Next 

                baris = baris + 1 

                flexGrid.Rows = baris + 1 

                flexGrid.TextMatrix(baris, 0) = !nip 

                flexGrid.TextMatrix(baris, 1) = !nama 

                flexGrid.TextMatrix(baris, 2) = !jenis_kelamin 

                flexGrid.TextMatrix(baris, 3) = !tempat_lahir 

                .MoveNext 

            Loop 

        End With 

    End If 

End Sub 

--------------------------------------------------------------------- 

 

Sub isiCmbFilter() 

    Dim i As Integer 

 

    Set rsPegawai = New ADODB.Recordset 

    stm = "select * from data_pegawai" 

    rsPegawai.Open stm, strconnect 

    For i = 0 To rsPegawai.Fields.Count - 1 

        cmbFilter.AddItem UCase(rsPegawai(i).Name) 

    Next i 

End Sub 

 

2.6. Form Ganti Password 

Form ganti password digunakan untuk melakukan penggantian password lama dengan password baru, hal ini 

sangat diperlukan untuk meningkatkan sistem keamanan sistem. Berikut adalah langkah-langkah 

pembuatannya 

1. Tambahkan satu form baru dengan Project > Add Project, pilih form kemudian klik Open. 

2. Desainlah form seperti pada gambar di bawah ini: 
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Gambar 5 Desain form ganti password 

 

3. Tambahkan beberapa objek sesuai dengan tabel dan susunlah objek-objek tersebut seperti pada 

gambar 5 

Objek Property Pengaturan 

Form Name 

BorderStyle 

MDIChild 

Caption 

Font 

frmGantiPassword 

4-FixedToolWindow 

True 

.: GANTI PASSWORD :. 

Segoe UI, regular, 9 

Label1 Caption Username 

Label2 Caption Password Lama 

Label3 Caption Password Baru 

Label4 Caption Retype Password Baru 

Text1 Name 

Appearance 

BorderStyle 

Text 

txtUsername 

0-Flat 

1-FixedSingle 

Text2 Name 

Appearance 

BorderStyle 

Text 

txtPassLama 

0-Flat 

1-FixedSingle 

Text3 Name 

Appearance 

BorderStyle 

Text 

txtPassBaru 

0-Flat 

1-FixedSingle 

Text4 Name 

Appearance 

BorderStyle 

Text 

txtRetypePass 

0-Flat 

1-FixedSingle 

Command1 Name 

Caption 

cmdGanti 

GANTI 

Command2 Name cmdKeluar 
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Caption KELUAR 

 

4. Ketikkan code listing dari frmGantiPassword di bawah ini kemudian simpan dengan nama 

frmGantiPassword.frm 

Dim rsPegawai As ADODB.Recordset 

Dim stm As String 

 

Private Sub cmdGanti_Click() 

    Dim rsPegawai2 As ADODB.Recordset 

    Dim stm2 As String 

     

    Set rsPegawai = New ADODB.Recordset 

    stm = "select count(username) as jumlah from admin where username='" & 

txtUsername.Text & "' and password='" & txtPassLama & "'" 

    rsPegawai.Open stm, strconnect 

     

    If rsPegawai!jumlah = 1 Then 

        If txtPassBaru.Text = txtRetypePass.Text Then 

            Set rsPegawai2 = New ADODB.Recordset 

             

            stm2 = "update admin set username='" & txtUsername.Text & "', password='" 

& txtPassBaru.Text & "'" 

            rsPegawai2.Open stm2, strconnect 

            MsgBox "Password Berhasil Diubah", vbInformation + vbOKOnly, "Informasi" 

            Call bersihkan_form 

        Else 

            MsgBox "Password baru tidak cocok", vbCritical + vbOKOnly, "Perhatian" 

            txtPassBaru.Text = "" 

            txtRetypePass.Text = "" 

            txtPassBaru.SetFocus 

        End If 

    Else 

        MsgBox "Username dan password lama yang anda masukkan salah", vbCritical + 

vbOKOnly, "Perhatian" 

        txtUsername.Text = "" 

        txtUsername.SetFocus 

    End If 

End Sub 

--------------------------------------------------------------------- 

 

Sub bersihkan_form() 

    txtUsername.Text = "" 

    txtPassLama.Text = "" 

    txtPassBaru.Text = "" 

    txtRetypePass.Text = "" 

End Sub 

--------------------------------------------------------------------- 
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Private Sub cmdKeluar_Click() 

    Unload Me 

End Sub 

--------------------------------------------------------------------- 

 

Private Sub Form_Load() 

    Move (Screen.Width - Width) / 2, (Screen.Height - Height) / 3 

     

    Call SQLConnection 

End Sub 

 

 


